
Console programs 
Console programs are programs that use text to communicate with the user and the environment, such as 
printing text to the screen or reading input from a keyboard. 
 
Console programs are easy to interact with, and generally have a predictable behavior that is identical across 
all platforms. They are also simple to implement and thus are very useful to learn the basics of a 
programming language: The examples in these tutorials are all console programs. 
 
The way to compile console programs depends on the particular tool you are using. 
 
The easiest way for beginners to compile C++ programs is by using an Integrated Development Environment 
(IDE). An IDE generally integrates several development tools, including a text editor and tools to compile 
programs directly from it. 
 
Here you have instructions on how to compile and run console programs using different free Integrated 
Development Interfaces (IDEs): 

 
IDE Platform Console programs 

Code::blocks Windows/Linux/MacOS Compile console programs using Code::blocks 

Visual Studio Express Windows Compile console programs using VS Express 2013 

Dev-C++ Windows Compile console programs using Dev-C++ 

 

 

Compilers 

The essential tools needed to follow these tutorials are a computer and a compiler toolchain 

able to compile C++ code and build the programs to run on it. 

 

C++ is a language that has evolved much over the years, and these tutorials explain many 

features added recently to the language. Therefore, in order to properly follow the tutorials, 

a recent compiler is needed. It shall support (even if only partially) the features introduced 

by the 2011 standard. 

 

Many compiler vendors support the new features at different degrees. See the bottom of 

this page for some compilers that are known to support the features needed. Some of them 

are free! 

 

If for some reason, you need to use some older compiler, you can access an older version of 

these tutorials here (no longer updated). 
 

 

What is a compiler? 

Computers understand only one language and that language consists of sets of instructions 

made of ones and zeros. This computer language is appropriately called machine language. 

 

A single instruction to a computer could look like this: 

00000 10011110 

 

A particular computer's machine language program that allows a user to input two numbers, 

http://www.cplusplus.com/doc/tutorial/introduction/codeblocks/
http://www.cplusplus.com/doc/tutorial/introduction/visualstudio/
http://www.cplusplus.com/doc/tutorial/introduction/devcpp/
http://www.cplusplus.com/doc/oldtutorial/


adds the two numbers together, and displays the total could include these machine code 

instructions: 

00000 10011110 

00001 11110100 

00010 10011110 

00011 11010100 

00100 10111111 

00101 00000000 

 

As you can imagine, programming a computer directly in machine language using only ones 

and zeros is very tedious and error prone. To make programming easier, high level languages 

have been developed. High level programs also make it easier for programmers to inspect 

and understand each other's programs easier. 

 

This is a portion of code written in C++ that accomplishes the exact same purpose: 

1 

2 

3 

4 
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int a, b, sum; 

      

cin >> a; 

cin >> b; 

              

sum = a + b; 

cout << sum << endl; 

 

 

 

Even if you cannot really understand the code above, you should be able to appreciate how 

much easier it will be to program in the C++ language as opposed to machine language. 

 

Because a computer can only understand machine language and humans wish to write in 

high level languages high level languages have to be re-written (translated) into machine 

language at some point. This is done by special programs called compilers, interpreters, or 

assemblers that are built into the various programming applications. 

 

C++ is designed to be a compiled language, meaning that it is generally translated into 

machine language that can be understood directly by the system, making the generated 

program highly efficient. For that, a set of tools are needed, known as the development 

toolchain, whose core are a compiler and its linker. 

 

 

 

 



How to write and compile C++ programs 

Compile using DevC++ compiler 

If you work on Windows and use DevC++, then editing and compiling is as 
easy as click of a button. DevC++ is an IDE which allows you to edit, compile, 
run and debug your program in the IDE itself.  If you want to install DevC++ 
then install it from DEV C++ website. 

1. Once you have installed and configured the software, Write and save 

your program using DevC++ itself. Create a new program by clicking 

on New  Project. 

 

  

1. Choose Empty Project from New Project dialog and choose a name 

for the program, in our case first and click Ok. 

 

1. Write the code of the program and save it. 



 

1. Click on Compile button (third row, first button) to compile your 

source code. If there are any errors in your program, then a window at 

the bottom will specify the warnings. 

2. After program is compiled, click on Run button (next to compile). 

3. However, DevC++ has a problem. As soon as you Run the program, 

output window opens momentarily and then it closes. So to come 

around this solution, set a breakpoint at the end of main function and 

then click on Debug instead of running it. 

 

1. When you run the program, output window will show the string. 



 

  

Compile using VC++ 

If you use Visual C++ toolkit for C++ programming, then the 
procedure is same as in DevC++. 

1. To write the source code>, Click on File  New Project. A dialog 

box will appear, click on A Empty Project and click Finish. Write 

your source code in the source code window. 

2. After you have saved your source code, click on Build button to 

compile the source code. 

3. Once the source code is compiled, click on Execute button to run the 

program. An output window will show the output of the program. 

 

In order to run a program and see it doing wonderful things, you 
should first write the program. The program can be written in any text 
editor, such as vi and emacs in Unix environment and using command 
prompt in DOS. There are also several Integrated Development 
Environment (IDE) packages available which provide a complete 
programming environment for C++ in which you can write, compile, run, 
and debug your program. 

C++ programs are saved with extensions .C, .cc, .cpp, .cxx depending on the 
platform you are working upon. 

Once you have saved a program, next stage is compiling it using a compiler 
which converts your C++ program into the object code which the computer 
can understand. 

Compile using g++ compiler 

If you are using UNIX environment and using g++ compiler, then compiling 
your C++ program is simple. After you have saved the program file, simply 
type the command 



g++ program.cc –o program 

where program is the name of the program. For example the name of our 
first program is first, then save it using extension “first.cc”. To compile, 
type 

g++ first.cc –o first 

To run the program, type first or ./first at the command prompt and your 
program will run. 

Run C++ in Windows (XP, 7, 8 and 10) 

To run C++ Programming in Windows, you’d need to download Code::Blocks. 

There are others available as well but Code::Blocks makes installation a piece 
of cake. 

It’s easy, simple and developer friendly. 

To make this procedure even easier, follow this step by step guide. 

1. Go to the binary release download page of Code:Blocks official 
site. 

 

2. Under Windows XP / Vista / 7 / 8.x / 10 section, click the link 
with mingw-setuphighlighted row either from Sourceforge.net or 
FossHub. 

3. Open the Code::Blocks Setup file and follow the instructions 
(Next > I agree > Next > Install); you don’t need to change 
anything. This installs the Code::Blocks with gnu gcc compiler, 
which is the best compiler to start with for beginners. 

http://www.codeblocks.org/downloads/26


4. Now, open Code::Blocks and go to File > New > Empty 
file (Shortcut: Ctrl+Shift+N) 

 

5. Write the C++ code and save the file with .cpp extension. To save 
the file, go to File > Save (Shortcut: Ctrl+S). Important: The 
filename should end with .cpp extension, like: hello.cpp, your-
program-name.cpp 

 

6. To run the program, go to Build > Build and Run (Shortcut: F9). 
This will build the executable file and run it. 

If your program doesn’t run and if you see error message "can't find compiler 
executable in your search path(GNU GCC compiler)",  go to Settings > 
Compiler > Toolchain executables  and click Auto-detect. This should 
solve the issue in most cases. 

 



 

Dev-C++ First steps tutorial 

Introduction 

This short tutorial is intended to lead the reader through the  basics of 
writing, compiling, linking and running simple console C++ programs using 
Dev-C++. 

Configuration of the linker 

Although standard settings should be completely sufficient in our sample, it 
is generally a good idea to ask the linker to include debugging information 
into the programs we are planning to compile, so as to easien the 
debugging phase. Here are the steps to recreate in order to alter this 
setting: 

         After having started Dev-C++, open the "Tools" menu, and select 
"Compiler Options". This will bring up the "Compiler Option" Dialog 
allowing you to set the way the compiler behaves in most of cases. 

         Pick the tab Settings, to access detailed setup of the compiler, and pick 
"Linker" category from the left hand side list. 

         On the right hand side, click on the end of the line "Generate debugging 
information" to bring up the drop down list allowing you to select the 
option's value. Select "Yes" to ask the linker to include debugging 
information (it will include such things as procedure names, source code 
references, ... into the generated executables), and finally click "OK" to 
validate your choice. This should bring you back to the main Dev-C++ 
screen. 

Creating a Dev-C++ Project 
Dev-C++ needs a project folder in order to store most of the data related to 
the compilation and linking (object files, executables, resources, ...). 
Therefore, the first thing you will want to do is create a project, even if 
your source code is extremely simple. Here is how you will create your 
project: 

         After having started Dev-C++, Open the "File" menu, and select "New >" 
- "Project" to bring up the "New Project" setup window, which is used 
by Dev-C++ as a Wizards dedicated to the creation of new projects. 



         In the "Basic" tab (that should be the one selected by default), select 
"Console Application" since that is the type of project this tutorial is 
focused on. You will be able to experiment with the other types of 
projects later, but this is out of the scope of this tutorial. 

         Give a meaningful name to your project, then click "OK" to proceed to 
the Project Location Selection. 

         Select the location where you would like the project file (*.dev) to be 
stored, and validate the file dialog to process. Dev-C++ will create a new 
source code file containing some starting code that will be possibly 
expanded to form the final executable. 

Creating a new source code file 
The project having been created, we will now start adding files to it. Dev-
C++ gives the possibility to add existing files to a project, but we will in our 
tutorial restrict ourselves to the creation of a new empty source code file. 
The one provided automatically by the New Project Wizard will be an 
excellent starting point. 

         Open the "File" menu, then select "Save All". This will save all resources 
that have been modified since the last save. In our case, only the newly 
created file has been modified, and since it is a new file, Dev-C++ will 
bring up a "Save File" dialog to let you specify where you would like this 
new file to be saved. 

         After having Selected the location and specified a meaningful name to 
the file, you might click OK to close the dialog and proceed to the 
modification of the initial file. 

         Since the default source code does not do much more than ask the user 
to press a key before terminating, we will start having it display some 
text. We will need the string class from the C++ Standard Template 
Library to build and store the string to be displayed.  Add the following 
line to the included headers: "#include<string>". 

         We will then need to declare a variable supposed to hold the string 
having to be displayed, and add the appropriate instruction to display 
this string on the console. Add the following at the beginning of "main" : 

string s = "text"; 

cout << s << endl << endl; 



         You can of course save the modified file again, but this is done 
automatically when you start the compilation of the project, which is 
why we will skip this step. 

Compiling, Building and Running a program 
The following instructions work for most of Dev-C++, except rare 
exceptions. The "Execute" menu is the place where you will find everything 
related to Compiling, Building and Running the program generated by your 
source code. Here are the steps to go through to achieve this: 

         Open "Execute" menu, then select Compile (Or use the key combination 
Control + F9). Please note that this will save all the modifications to 
project files before proceeding.  This step is done automatically before 
running the resulting executable (see next step for running the 
executable), if it had not been compiled already.  Dev-C++ will bring up 
a progress dialog showing you the different states (mostly compilation 
and linking) of the compilation process. 

         Once finished, click "Close" to terminate the compilation process. 

         If Dev-C++ did not report any compilation error, that means the 
program has been compiled successfully, and you can now start it from 
within Dev-C++. To do so, open "Execute" menu, and select "Run" (or 
use the key combination Control + F10). Please note that this will 
compile the program before proceeding, if it had not been compiled 
already. From this point on, Dev-C++ will launch a command-line shell, 
and start running the program into it. You can set additional parameters 
(Command line parameters for example) for the program, using Project 
Settings. 

         After having ran the program, the 
command system("PAUSE") included into the source file 
before main() return will pause the execution until you press a key, so 
that you get the possibility to view eventual results before the 
execution window closes itself. 

As a short summary for this section, simply note that it is usually enough to 
press Control + F10 to have Dev-C++ sequentially save the project, try to 
compile it (it will alert on errors so that you can correct them before 
proceeding), try to build it (it will alert on errors), and finally run it. 

  

Finally, you can close project files using the "File" menu, and selecting the 
option "Close Project". 



 

Microsoft Visual C++ 6.0 First steps tutorial 
This short tutorial is intended to lead the reader through the  basics of writing, compiling, 
linking and running simple console C++ programs using Microsoft Visual C++ 6.0. 

 

Creating a Microsoft Visual C++ 6.0 Project 

Microsoft Visual C++ 6.0 needs a project folder in order to store most of 
the data related to the compilation and linking (object files, executables, 
resources, ...). Therefore, the first thing you will want to do is create a 
project, even if your source code is extremely simple. Here is how you will 
create your project: 

         After having started Microsoft Visual C++ 6.0, Open the "File" menu, 
and select "New..." (You can also press the key combination Control + N 
instead) to bring up the "New" setup window, which is used by 
Microsoft Visual C++ 6.0 to launch all the Wizards dedicated to the 
creation of new files and resources. 

         Select the tab labeled "Projects" to start the creation of your new 
project. Since we are experimenting on console C++ programs, select 
"Win32 Console Application" from the list. 

         Give a meaningful name to your project, then browse to the hard disk 
location you want it to be stored to. Please take note that Microsoft 
Visual C++ 6.0 will take care of creating the project directory if it does 
not already exist. 

         Click "OK" to validate your input, and start the project creation Wizard. 

         Although you might find interesting to try out sample applications 
offered by the Wizard, we will in our present case be completely 
satisfied by an empty project. We will add files to it later. 

         After having clicked the "Finish" button, you will get a summary of the 
project Setup. In this case, the summary is extremely short, as you 
would expect from an empty project. Click "OK" to proceed with the 
creation of the project. 

         Default installations of Microsoft Visual C++ 6.0 should display a toolbar 
on the left hand side of the screen, offering you a class view (listing 
classes and global members of the project) as well as a file view 
(recapitulating the list of source files used by the project). If applicable, 



you might also get a Resource view tab on this toolbar, but this is not 
the case in our current project. If you don't see this toolbar, you can 
make it appear by selecting it from the "View" menu. 

Creating a new source code file 
The project having been created, we will now start adding files to it. 
Microsoft Visual C++ 6.0 gives the possibility to add existing files to a 
project (Via the "Project" menu), but we will in our tutorial restrict 
ourselves to the creation of a new empty source code file. Here are the 
steps required to achieve this: 

         Bring up the "New" setup window by selecting the "New..." option from 
the "File" menu (Or by pressing Control + N key combination). 

         From the "Files" tab (Usually selected by default), select the list item 
labeled C++ Source file, then give it a meaningful name. If you have 
several active projects open, you can choose to which project the file 
should belong, by checking "Add to project" option and selecting the 
corresponding project. A new file can not be added to several projects 
at once. If you want to include a file to an additional project, you will 
have to use the file importation from the other project's "Project" 
menu. 

         Once you have submitted your input by clicking the "OK" button, 
Microsoft Visual C++ 6.0 fires the source code editor, and updates the 
File view. 

         Finally, type the content you wish into the file, using the editor. 

         Select "Save all" from the "File" menu to save all the data related to the 
project. Please note that this step is done automatically before 
compiling the project (see next section for compiling instructions) if the 
project had not been saved already. 

Compiling, Building and Running a program 
The following instructions work for most of Microsoft Visual C++ 6.0 
projects, except rare exceptions. The "Build" menu is the place where you 
will find everything related to Compiling, Building and Running the program 
generated by your source code. Here are the steps to go through to achieve 
this: 

         Open "Build" menu, then select Compile (Or use the key combination 
Control + F7). Please note that this will save all the modifications to 
project files before proceeding. This step is done automatically before 



building the project (see next step for building instructions) if the 
project had not been compiled already. 

         If there have been not compilation errors, you can proceed to building 
step. Open "Build" menu, and select Build (Or press F7). Please note 
that this will compile the project if required, before proceeding to the 
building phase. This step is done automatically before running the 
resulting executable (see next step for running the executable), if it had 
not been built already. 

         If Microsoft Visual C++ 6.0 did not report any building error, that means 
the program has been built successfully, and you can now start it from 
within Microsoft Visual C++ 6.0. To do so, open "Build" menu, and select 
Execute (or use the key combination Control + F5). Please note that this 
will build the program before proceeding, if it had not been built 
already. From this point on, Microsoft Visual C++ 6.0 will launch a 
command-line shell, and start running the program into it. You can set 
additional parameters (Command line parameters for example) for the 
program, using Project settings ("Project" menu, or Alt + F7). 

         After having ran the program, Microsoft Visual C++ 6.0 will pause the 
execution until you press a key, so that you get the possibility to view 
eventual results before the execution window closes itself. 

As a short summary for this section, simply note that it is usually enough to 
press Control + F5 to have Microsoft Visual C++ 6.0 sequentially save the 
project, try to compile it (it will alert on errors so that you can correct them 
before proceeding), try to build it (it will alert on errors), and finally run it. 

Note: The resulting executable can be found in a "debug\" sub folder within 
project directory. 

  

Finally, you can close project files using the "File" menu, and selecting the 
option "Close Workspace". 

You might have to confirm your choice in a Dialog Box. However, this step 
is not mandatory since Microsoft Visual C++ 6.0 allows you to create new 
projects or to close the application while you have a project open in it. 

 



Microsoft Visual C++ .NET 2003 Tutorial 

Introduction 

This short tutorial is intended to lead the reader through the  basics of 
writing, compiling, linking and running simple console C++ programs using 
Microsoft Visual C++ .NET. 2003 / 2005 

 

Creating a Microsoft Visual C++ .NET Project 

Microsoft Visual C++ .NET needs a project folder in order to store most of 
the data related to the compilation and linking (object files, executables, 
resources, ...). Therefore, the first thing you will want to do is create a 
project, even if your source code is extremely simple. Here is how you will 
create your project: 

         After having started Microsoft Visual C++ .NET, Open the "File" menu, 
and Hover over "New", then select "Project..." (You can also press the 
key combination Control + Shift + N instead) to bring up the "New 
Project" setup window, which is used by Microsoft Visual C++ .NET to 
launch all the Wizards dedicated to the creation of new projects. 

         Since we are experimenting on console C++ programs, select "Win32 
Console Application" from the list. You might of course try the other 
types of projects, once you are done with this tutorial, but it would be 
outside of our scope to describe them all. 

         Give a meaningful name to your project, then browse to the hard disk 
location you want it to be stored to. Please take note that Microsoft 
Visual C++ .NET will take care of creating the project directory if it does 
not already exist. 

         Click "OK" to validate your input, and start the project creation Wizard. 

         Select "Application Settings" 

         Although you might find interesting to try out sample applications 
offered by the Wizard, we will in our present case be completely 
satisfied by an empty project. We will add files to it later. 

         After having clicked the "Finish" button, you will finally be able to start 
adding files to your newly created project. 

Creating a new source code file 
The project having been created, we will now start adding files to it. 
Microsoft Visual C++ .NET gives the possibility to add existing files to a 



project (Via the "Project" menu), but we will in our tutorial restrict 
ourselves to the creation of a new empty source code file. Here are the 
steps required to achieve this: 

         Bring up the "Add New Item" setup window by right-clicking or "Source 
Files" folder on left hand side view, then selecting "Add >" - "New Item" 
(or selecting the "New..." option from the "File" menu, or by pressing 
Control + N key combination) 

         From the main panel, select the list item labeled C++ File (.cpp), then 
give it a meaningful name. 

         Once you have submitted your input by clicking the "Add" button, 
Microsoft Visual C++ .NET fires the source code editor, and updates the 
Solution Explorer (the tab on the left hand side showing you the list of 
files and resources attached to the project). 

         Finally, type the content you wish into the file, using the editor. 

         Select "Save all" from the "File" menu to save all the data related to the 
project. Please note that this step is done automatically before 
compiling the project (see next section for compiling instructions) if the 
project had not been saved already. 

Compiling, Building and Running a program 
The following instructions work for most of Microsoft Visual C++ .NET 
projects, except rare exceptions. The "Build" menu is the place where you 
will find everything related to Compiling, Building and Running the program 
generated by your source code. Here are the steps to go through to achieve 
this: 

         Open "Build" menu, then select "Build Solution" (Or press F7) to 
compile and build the project in a single step. Please note that this 
action will save all the modifications to project files before proceeding, 
if they have been modified since their last save. This step is done 
automatically before running the resulting executable (see next step for 
running the executable), if it had not been built already. 

         If Microsoft Visual C++ .NET did not report any building error, that 
means the program has been built successfully, and you can now start it 
from within Microsoft Visual C++ .NET. To do so, open "Debug" menu, 
and select "Start Without Debugging" (resp. "Start Debugging" if you 
want a step by step execution) (or use the key combination Control + F5 
(resp. F5)). Please note that this will build the program before 
proceeding, if it had not been built already. From this point on, 



Microsoft Visual C++ .NET will launch a command-line shell, and start 
running the program into it. You can set additional parameters 
(Command line parameters for example) for the program, using Project 
settings ("Project" menu, or Alt + F7). 

         After having ran the program, Microsoft Visual C++ .NET will pause the 
execution until you press a key, so that you get the possibility to view 
eventual results before the execution window closes itself. Please note 
that Microsoft Visual C++ .NET is the one forcing this pause. If you plan 
to start the built executable independently from Microsoft Visual C++ 
.NET, you will have to insert this pause if you want to prevent the 
application from closing itself before the user gets the chance to see 
eventual output, in case the application would not be started from the 
command-line. 

As a short summary for this section, simply note that it is usually enough to 
press Control + F5 to have Microsoft Visual C++ .NET sequentially save the 
project, try to compile it (it will alert on errors so that you can correct them 
before proceeding), try to build it (it will alert on errors), and finally run it. 

  

Finally, you can close project files using the "File" menu, and selecting the 
option "Close Solution". 

However, this step is not mandatory since Microsoft Visual C++ 6.0 allows 
you to create new projects or to close the application while you have a 
project open in it. 

 

Visual Studio Express 
Visual Studio Express for Windows Desktop is a tool from Microsoft that integrates a 

development interface and the toolchains needed to compile a variety of programming 

languages. 

 

It is a reduced version of Visual Studio available as a free program to download from: 

 

http://www.microsoft.com/express/  

 

Note that Express comes in a variety of versions. The one needed to compile console 

programs is Express for Windows Desktop (neither Express for Web nor Express for 

Windows will do). 
 

 

Installation 

http://www.microsoft.com/express/


Run the executable (if it is an ISO, open the ISO file and run the executable within). 

Then follow the instructions given by the installer. 
 

 

Support for C++11 

The C++ compiler integrated with Visual Studio Express supports many features 

introduced by the recent standard, enough to follow the tutorials in this site off the 

box. 
 

 

Console Application 

Both Visual Studio and its free Express version are designed to build a variety of 

applications. For the tutorials, we are interested in compiling and running simple 

console applications. 

 

To compile and run a simple console application in Visual Studio Express: 

 

File -> New Project...  

 

  

 

Here, on the left-hand side, select Templates -> Visual C++. Then, on the central 

part, select Win32 Console Application: 

 



 

 

On the bottom, you have the option to give a name to the project and select a location 

where the files will be stored. The default options are fine, but you can also change 

them to better fit your needs. 

 

Now click [OK]  

This will open the Win32 Application Wizard: 

 



  

 

Click [Next]. 

 



  

 

Leave "Console application" selected, and in Additional options select Empty 

project. Other options are not needed, but won't bother either. 

 

Now we have an empty project. We need to add a file to it. For that: 

 

On the Solution Explorer at right, look for Source Files under your application. Right-

click -> Add -> New Item... 

 



 

 

Here, add a new C++ file: 

 



  

 

You can give it any name you want with a .cpp extension, such as example.cpp. 

After clicking OK, the main window will display en editor to edit this new C++ file. 

Write the following in it: 

1 

2 

3 

4 

5 

6 

#include <iostream> 

int main() 

{ 

  auto x = R"(Hello world!)"; 

  std::cout << x; 

} 

Edit & Run 

 

 

Then, to compile and run this application simply press Ctrl+F5. 

 

You can edit this file as much as needed and trigger a new Compile-and-Run every 

time when ready. 

 

 

 

http://www.cplusplus.com/doc/tutorial/introduction/visualstudio/


Visual Studio 

You can use Visual C++ in the Visual Studio integrated development environment (IDE) to create Standard C++ programs. By following the steps in this 

walkthrough, you can create a project, add a new file to the project, modify the file to add C++ code, and then compile and run the program by using Visual 

Studio. 

You can type your own C++ program or use one of the sample programs. The sample program in this walkthrough is a console application. This application 

uses the set container in the Standard Template Library (STL). 

Visual C++ complies with the 2003 C++ Standard, with these major exceptions: two-stage name lookup, exception specifications, and export. Additionally, 

Visual C++ supports several C++0x features, for example, lambdas, auto, static_assert, rvalue references, and extern templates. 

Prerequisites 

To complete this walkthrough, you must understand the fundamentals of the C++ language. 

To create a project and add a source file 
1. Create a project by pointing to New on the File menu, and then clicking Project. 

2. In the Visual C++ project types pane, click Win32, and then click Win32 Console Application. 

3. Type a name for the project. 

By default, the solution that contains the project has the same name as the project, but you can type a 

different name. You can also type a different location for the project. 

Click OK to create the project. 

4. In the Win32 Application Wizard, click Next, select Empty Project,and then click Finish. 

5. If Solution Explorer is not displayed, on the View menu, click Solution Explorer. 

6. Add a new source file to the project, as follows. 

a. In Solution Explorer, right-click the Source Files folder, point to Add, and then click New Item. 

b. In the Code node, click C++ File (.cpp), type a name for the file, and then click Add. 

The .cpp file appears in the Source Files folder in Solution Explorer, and the file is opened in the Visual 

Studio editor. 

7. In the file in the editor, type a valid C++ program that uses the Standard C++ Library, or copy one of the 

sample programs and paste it in the file. 

For example, you can use the set::find sample program, which is one of the the Standard Template Library 

samples that are included in Help. 

If you use the sample program, notice the using namespace std; directive. This directive 

enables the program to use cout and endl without requiring fully qualified names 

(std::coutand std::endl). 

8. Save the file. 

9. On the Build menu, click Build Solution. 

The Output window displays information about the compilation progress, for example, the location of the 

build log and a message that indicates the build status. 

10. On the Debug menu, click Start without Debugging. 

If you used the sample program, a command window is displayed and shows whether certain integers are 

found in the set. 

 

 

Visual C++ includes a command-line C++ compiler that you can use to create everything from basic console apps to Universal Windows apps, Windows 

Store apps, and .NET components. 

In this walkthrough, you create a basic, "Hello, World"-style C++ program by using a text editor, and then compile it on the command line. If you'd like to try 

the Visual Studio IDE instead of using the command line, see Walkthrough: Working with Projects and Solutions (C++) or Using the Visual Studio IDE for 

C++ Desktop Development. 

In this walkthrough, you can use your own Visual C++ program instead of typing the one that's shown, or you can use a Visual C++ code sample from 

another help article. 

Prerequisites 

To complete this walkthrough, you must have installed either Visual Studio and the optional Visual C++ components, or the Microsoft Visual C++ Build 

Tools. 

Visual Studio is a powerful integrated development environment that supports a full-featured editor, resource managers, debuggers, and compilers for many 

languages and platforms. For information on these features and how to download and install Visual Studio, including the free Visual Studio Community 

edition, see VisualStudio.com. 

The Microsoft Visual C++ Build Tools installs only the command-line compiler, tools, and libraries you need to build C and C++ programs. It's perfect for 

build labs or classroom exercises and installs relatively quickly. To install only the command-line tools, download and install Microsoft Visual C++ Build Tools 

2015. 

Before you can build a C or C++ program on the command line, you must verify that the tools are installed, and that you can access them from the 

command line. Visual C++ has complex requirements for the command-line environment in order to find the tools, headers, and libraries it uses. You can't 

use Visual C++ in a plain command prompt window. Fortunately, Visual C++ installs shortcuts for you to launch a developer command prompt that has 

the environment set up for command line builds. Unfortunately, the names of the developer command prompt shortcuts and where they are located are 

different in almost every version of Visual C++ and on different versions of Windows. Your first walkthrough task is finding the right one to use. 

https://msdn.microsoft.com/en-us/library/ets82w6a.aspx
https://msdn.microsoft.com/en-us/library/bb384842.aspx
https://msdn.microsoft.com/en-us/library/bb384847.aspx
https://msdn.microsoft.com/en-us/library/bb384847.aspx
https://www.visualstudio.com/
http://go.microsoft.com/fwlink/?LinkId=691126
http://go.microsoft.com/fwlink/?LinkId=691126


Open a developer command prompt 
1. If you have installed Visual Studio 2015 on Windows 10, open the Start menu 

and choose All apps. Scroll down and open the Visual Studio 2015 folder 

(not the Visual Studio 2015 app). Choose Developer Command Prompt for 

VS2015 to open the command prompt window. 

If you have installed Microsoft Visual C++ Build Tools 2015 on Windows 10, 

open the Startmenu and choose All apps. Scroll down and open the Visual 

C++ Build Tools folder. Choose Visual C++ 2015 x86 Native Tools 

Command Prompt to open the command prompt window. 

If you are using a different version of Visual Studio or are running a different 

version of Windows, look in your Start menu or Start page for a Visual Studio 

tools folder that contains a developer command prompt shortcut. You can also 

use the Windows search function to search for "developer command prompt" 

and choose one that matches your installed version of Visual Studio. Use the 

shortcut to open the command prompt window. 
2. Next, verify that the Visual C++ developer command prompt is set up correctly. In the command prompt window, enter cl and 

verify that the output looks something like this: 

1. Output 

2. C:\Program Files (x86)\Microsoft Visual Studio 14.0>cl   
3. Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23918 for 

x86   

4. Copyright (C) Microsoft Corporation.  All rights reserved.   
5.  
6. usage: cl [ option... ] filename... [ /link linkoption... ]   
7.  

There may be differences in the current directory or version numbers, depending on the version of Visual C++ and any updates installed. If this 

is similar to what you see, then you are ready to build C or C++ programs at the command line. 

 Note 

If you get an error such as "'cl' is not recognized as an internal or external 

command, operable program or batch file," error C1034, or error LNK1104 

when you run the clcommand, then either you are not using a developer 

command prompt, or something is wrong with your installation of Visual C++. 

You must fix this issue before you can continue. 

If you can't find the developer command prompt shortcut, or if you get an error message when you enter cl, then your Visual C++ 

installation may have a problem. Try reinstalling the Visual C++ component in Visual Studio, or reinstall the Microsoft Visual C++ Build Tools. 

Don't go on to the next section until this works. For more information about installing and troubleshooting Visual C++, see Installing Visual 

Studio 2015. 

 Note 

Depending on the version of Windows on the computer and the system 

security configuration, you might have to right-click to open the shortcut menu 

for the developer command prompt shortcut and then choose Run as 

Administrator to successfully build and run the program that you create by 

following this walkthrough. 

Create a Visual C++ source file and compile it on the 

command line 
1. In the developer command prompt window, enter md c:\hello to create a directory, and then enter cd c:\hello to change to that directory. 

This is the directory that your source file and the compiled program are created in. 



2. Enter notepad hello.cpp in the command prompt window. 

Choose Yes when Notepad prompts you to create a file. This opens a blank Notepad window, ready for you to enter your code in a file named 

hello.cpp. 

3. In Notepad, enter the following lines of code: 

C++ 

#include <iostream>   

using namespace std;   

void main()   

{   

    cout << "Hello, world, from Visual C++!" << endl;   

}   

 

This is a very simple program that will write one line of text on the screen and then exit. To minimize errors, copy this code and paste it into 

Notepad. 

4. Save your work! In Notepad, on the File menu, choose Save. 

Congratulations, you have created a Visual C++ source file, hello.cpp, that is ready to compile. 

5. Switch back to the developer command prompt window. Enter dir at the command prompt to list the contents of the c:\hello directory. You 

should see the source file hello.cpp in the directory listing, which looks something like this: 

Output 

c:\hello>dir   

 Volume in drive C has no label.   

 Volume Serial Number is CC62-6545   

 

 Directory of c:\hello   

 

05/24/2016  05:36 PM    <DIR>          .   

05/24/2016  05:36 PM    <DIR>          ..   

05/24/2016  05:37 PM               115 hello.cpp   

               1 File(s)            115 bytes   

               2 Dir(s)  571,343,446,016 bytes free   

 

 

The dates and other details will differ on your computer. If you don't see your source code file, hello.cpp, make sure you've changed to the 

c:\hello directory you created, and in Notepad, make sure that you saved your source file in this directory. Also make sure that you saved the 

source code with a .cpp file name extension, not a .txt extension. 

6. At the developer command prompt, enter cl /EHsc hello.cpp to compile your program. 

The cl.exe compiler generates an .obj file that contains the compiled code, and then runs the linker to create an executable program named 

hello.exe. This name appears in the lines of output information that the compiler displays. The output of the compiler should look something 

like this: 

Output 

c:\hello>cl /EHsc hello.cpp   

Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23918 for 

x86   

Copyright (C) Microsoft Corporation.  All rights reserved.   

 

hello.cpp   

Microsoft (R) Incremental Linker Version 14.00.23918.0   

Copyright (C) Microsoft Corporation.  All rights reserved.   

 

/out:hello.exe   

hello.obj   

 

 Note 



If you get an error such as "'cl' is not recognized as an internal or external 

command, operable program or batch file," error C1034, or error LNK1104, 

your developer command prompt is not set up correctly. For information on 

how to fix this issue, go back to the Open a developer command 

prompt section. 

 Note 

If you get a different compiler or linker error or warning, review your source 

code to correct any errors, then save it and run the compiler again. For 

information about specific errors, use the search box on this MSDN page to 

look for the error number. 

7. To run the hello.exe program, at the command prompt, enter hello. 

The program displays this text and exits: 

Output 

Hello, world, from Visual C++!   

 

Congratulations, you've just compiled and run a C++ program by using the command-line tools. 

 

 

 

 


